Tile Server Plug-Ins for SBuilderX

This is the Forum to discuss the use of SBuilderX (version 3.10 and above). For previous versions of SBuilder please use the "SBuilder for Flight Simulator FS2004" forum.
User avatar
luisfeliztirado
Posts: 436
Joined: Sun May 15, 2005 9:15 am
Location: Santo Domingo

Re: Tile Server Plug-Ins for SBuilderX

Post by luisfeliztirado » Fri Feb 05, 2016 5:22 pm

HERE Maps does not supply the dlls used by SBuilderX.

While they are installed with the application, Luis Sá assumes no liability for the use that people might make of them. Please remember that satellite and aerial images and maps on all those servers are licensed copyrighted material and may not be used without the express authorization of the copyright holders.

However, we have noted that some users have released scenery made with these images, both free and commercial, and up to now I haven't heard of Google's legal department going after anybody.

Still, you are on your own when it comes to the image server dlls. This particular dll has been maintained, I believe, by Dick Ludowise and you could ask him to take a look.

However, Dick always includes the simple source code for the dll, so you could also take a look at it, then check the documentation at the HERE developers web site

https://developer.here.com/applications

and then modify Dick's file yourself. You will need to compile it into a dll so you should get the free version of Microsoft Visual Studio and that's about it.

NOTE: I just checked and Dick no longer includes the source for the dlls, so just ask him and if he has the time, he will most likely fix the problem.

Best regards.
Luis

Zappa
Posts: 14
Joined: Fri Jan 15, 2016 6:24 pm

Re: Tile Server Plug-Ins for SBuilderX

Post by Zappa » Fri Feb 05, 2016 5:55 pm

Yes, I would agree. No problems with SBX at all, only the Nokia Imagery Plug in now seems outdated.
I have noticed that HERE's required base URL for the Satellite Map Tile API does seem to have changed slightly from
"http://1.aerial.maps.api.here.com/mapti ... llite.day/" to
"http://1.aerial.maps.cit.api.here.com/m ... llite.day/"
However, I made this change to the dll but it made no difference (Although, never having used Visual Basic before it's very possible I did something wrong - It's a bit of a steep learning cliff!)

Rilex
Posts: 3
Joined: Tue Feb 02, 2016 3:18 pm

Re: Tile Server Plug-Ins for SBuilderX

Post by Rilex » Sat Feb 06, 2016 12:42 am

iangbusa wrote:Just FYI - I do have 314 working on Win 10 so let us know what your problems are and perhaps we can help? (And thanks to all those on forums here particularly the Luis'es and Gary who helped me to get it going (in Win 8) when 314 came out. Subsequently it worked without any problems on 8.1 and 10. Fingers-crossed and knock on wood (I'm not superstitious).
Yeah, works great, except it crashes every time I click Compile. Also randomly crashes while view map is on, and it's 10 times more laggy and slower than previous version.

User avatar
luisfeliztirado
Posts: 436
Joined: Sun May 15, 2005 9:15 am
Location: Santo Domingo

Re: Tile Server Plug-Ins for SBuilderX

Post by luisfeliztirado » Sat Feb 06, 2016 12:56 am

Since nobody else is reporting these issues, it seems clear that the problem is on your side. You should review your Windows installation and check your hardware.

Zappa
Posts: 14
Joined: Fri Jan 15, 2016 6:24 pm

Re: Tile Server Plug-Ins for SBuilderX

Post by Zappa » Sun Feb 07, 2016 10:25 am

Well, it appears as though I've got a solution (of sorts) for the Nokia Imagery Plug-in but it's good news and bad news I'm afraid.
The good news is that I have managed to get it to work again, however......
The bad news is that to get it to work I've had to incorporate my own HERE app and id codes into the dll (so I hope you can forgive me if I don't upload it here)
Note:- This only applies to the "NokiaImagery" plug-in and the "Add Map - From background..." option. It does not effect "Add Map - From Here (Nokia)..."

If you'd like to give it a whirl, this is what I used, and what I did....

I used "JetBrains dotPeek" and "Visual Studio Express 2013" (both free) Some working knowledge of these would be most useful but by no means necessary (I manged to muddle through in the end) Be prepared for a large download if you don't have these already.

Disclaimer:-
This is only a tiny mod to Dick Ludowise's original plug-in without whom, none of this would have been possible. (Many thanks to Dick for all your plug-ins. You're a legend!)
I'm a total nOOb at this sort of thing so expect it to fail but if it does happen to work, then that's a bonus!
I make no claims that this is the only way (or even the best way) of modding this dll (In fact, I'm amazed it worked for me at all)
This is only a very general procedure and does not describe every step in detail.
Please make back ups first! I don't wont you to go and spoil anything now.
For SBX 3.14 only.

1. De-compile the original dll (I did this using "JetBrains dotPeek") and export it to Visual Studio Express.
2. In VS Express you'll need to make the following changes:-
a) In the Solution Explorer expand "NokiaSatelliteServer" as necessary and double click "C# NokiaImagery.cs" to open and change all 4 BaseURL's to include "cit" i.e.
1.aerial.maps.cit.api.here.com/maptile/2.1/maptile/newest/satellite.day/
b) In the Solution Explorer again, expand "C# NokiaSatellite.cs" & "nokiaSatellite" and double click "DownloadTile" to open. Just a few lines down from here you should see the following line. Change it to include your HERE app and id code. (Don't add the spaces and brackets to your id and code as I've done below, this is only for clarity)
string str = Zoom.ToString() + "/" + X.ToString() + "/" + Y.ToString() + "/256/jpg?app_id= [your id] &app_code= [your code] ";
3) Next we need to add the TileServer.DLL that's in SBX to our project so that we can build it. So it's back to Solution Explorer again, right click "References" and click "Add Reference...". Expand the "Browse" tab and click the "Browse" button at the bottom right to search for the TileServer.DLL. (Yours should be saved somewhere like this "C:\Program Files\SBuilderX314") and click OK.
4) Select "Release" and click "Start" to build your new dll.
5) Copy your new dll into SBX's "Tiles" folder and over right as usual.
...and that's it!

Very best of luck to you and happy SBXing!
Gary.

Robbert
Posts: 16
Joined: Fri Nov 21, 2008 4:46 am

Re: Tile Server Plug-Ins for SBuilderX

Post by Robbert » Tue Apr 12, 2016 12:26 pm

Hi Dick

This morning I'm only getting tiles from VE Satellite, non from google, maybe slow internet on my side or has google earth code change again.... :roll: just curious

Regards Robbert

Zappa
Posts: 14
Joined: Fri Jan 15, 2016 6:24 pm

Re: Tile Server Plug-Ins for SBuilderX

Post by Zappa » Tue Apr 12, 2016 6:48 pm

Hi Robert,
Yes, Google Earth has gone through a similar change as Nokia did recently. I have tried to tweak Dick's Plug-in and although I could get it loading tiles again, their locations were all messed up. I also couldn't see a way to disable the Google logo and copyright from appearing at the bottom of each tile. You'll also need to get a free Google Static Maps API Key from https://developers.google.com/maps/docu ... atic-maps/ however, this will still need linking to an updated Google Tile Server.
Fingers crossed that Dick can sort this out for us all once again.
Hopefully,
Gary

rhumbaflappy
Posts: 419
Joined: Sat Oct 16, 2004 10:11 pm

Re: Tile Server Plug-Ins for SBuilderX

Post by rhumbaflappy » Tue Apr 12, 2016 11:12 pm

This might be a glitch in google's service. I'm getting tiles in SBX.

Dick
Dick

Zappa
Posts: 14
Joined: Fri Jan 15, 2016 6:24 pm

Re: Tile Server Plug-Ins for SBuilderX

Post by Zappa » Wed Apr 13, 2016 6:44 pm

Hi Dick,
Thanks for the reply. I've just re tried SBX again but unfortunately still no new tiles being downloaded with Google.
SBX will re load tiles in places where I've already been before however it won't download tiles for new areas. Could this be what you're seeing or are the tiles your getting also for new areas?
Cheers,
Gary

rhumbaflappy
Posts: 419
Joined: Sat Oct 16, 2004 10:11 pm

Re: Tile Server Plug-Ins for SBuilderX

Post by rhumbaflappy » Wed Apr 13, 2016 9:11 pm

You probably need to delete your Tiles/GoogleSatellite folder. SBX displays stored tiles first, and if your folder has blanks, then it will show blanks in the program. (The folder will rebuild itself, and store new tiles).

As of right now, I download Google tiles very quickly. They can't be stored as I first delete the folder to make sure. What version of the DLL are you using, and was it previously working with this DLL?

Dick
Dick

Zappa
Posts: 14
Joined: Fri Jan 15, 2016 6:24 pm

Re: Tile Server Plug-Ins for SBuilderX

Post by Zappa » Thu Apr 14, 2016 6:30 pm

Hi Dick,
Well, I tried deleting the Google Satellite folder as you suggested but unfortunately I'm still only getting blank tiles. I also tried with SBX 3.13 but I'm getting the same thing.
I'm using Google Server V186 and it had been working fine up until about a month ago.
Thanks again for your help and ideas.
Gary.

rhumbaflappy
Posts: 419
Joined: Sat Oct 16, 2004 10:11 pm

Re: Tile Server Plug-Ins for SBuilderX

Post by rhumbaflappy » Thu Apr 14, 2016 6:44 pm

I have a newer Google Server:

Google Server v196

Dick
Dick

Zappa
Posts: 14
Joined: Fri Jan 15, 2016 6:24 pm

Re: Tile Server Plug-Ins for SBuilderX

Post by Zappa » Thu Apr 14, 2016 6:50 pm

Hey, what a star you are! That's done the trick. Firing on all four again.
Thanks Dick.

Robbert
Posts: 16
Joined: Fri Nov 21, 2008 4:46 am

Re: Tile Server Plug-Ins for SBuilderX

Post by Robbert » Tue Apr 19, 2016 7:36 pm

Thank you !!!! Dick

hypernautic
Posts: 2
Joined: Mon May 16, 2016 5:10 am

Using new dll can't zoom after 3

Post by hypernautic » Wed May 18, 2016 4:21 am

I can't zoom after zoom level 3, and then everything becomes compositely white. I am using google server 196, so I really can't understand what I'm doing wrong. I have already enabled google satellite in the preferences.

Thanks!

Post Reply